EOB Services Degradation

Incident Report for Anatomy Financial

Resolved

This issue has been identified and resolved.
Posted Mar 04, 2026 - 22:35 UTC

Investigating

We are currently investigating an issue related to EOB services. We will update as information becomes available.
Posted Mar 04, 2026 - 22:08 UTC
This incident affected: EOB Digitization.